You can find part 1 here.

The Software

I started by installing a copy of XP Pro I had lying around, once that was running I set about the PVR software.

I initially installed GB-PVR. It’s not open source, but is free, and seems to have a lot of support. It is actually designed as two pieces of software, a back-end recorder/scheduler and a front-end for controlling it and playback, they can be run on the same or separate machines (so you could have a media server somewhere running all the time and something like a Hauppauge MediaMVP controlling it, which GB-PVR has good support for). I had checked the transmitter used on my PVR so I could pick the TV transmitter to use and got on with setting up GB-PVR.

I have to say that it was far from the most intuitive setup I have ever done, and don’t get me wrong, I’m good with computers, well into expert, which means this would probably be bewildering for normal users. It found my hardware without issue, but whenever I tried to search for channels it found nothing. I checked everything twice, spent a long time using Google and hunting forums, no joy. I gave up and installed Media Portal.

I liked Media Portal better from the start and it was a bit easier to get my head around. Still no joy finding channels though. I installed the WinTV software that came the TV card and it found channels. So, no problem with the reception or hardware. I spent a long time searching online for help and in the end I found out about ScanChannelsBDA_UK (I have mirrored a copy here as I had to sign up to download a copy, the only place I found it online). That found channels, and from which transmitter it found them, turns out I was using the wrong one. Back into GB-PVR and it found the channels. I tried in Media Portal, still no joy. So I finished setting up GB-PVR and it was all working. I had to install a copy of PowerDVD I had lying around to get MPEG2 encoders/decoders though.

After a brief use I wasn’t happy with it. The TV picture seemed to jerk, like it was dropping frames, which made it difficult to watch. More than that though, the interface felt old and ugly, clunky to use. I thought I’d give Media Portal another try. I figured I would uninstall GB-PVR as it may be conflicting, I was right, that sorted the problem and I was OK to set Media Portal up. I was much happier with it from the start, still a few weird things in the interface, but it looked nicer and seemed to work better.

I spent the first week tweaking and changing settings. Initially I had a problem that the sound went weird when I tried to record, which I tracked down to the MPEG encoder I had chosen (Media Portal comes with some encoders and decoders, unlike GB-PVR). I added a plugin to launch external applications and added IE so you could easily launch a browser and surf the net. I also enabled the My Burner plugin so I could, I hoped, burn saved files straight to DVD (as I mentioned, part of my reason for disliking me current PVR was the work involved in doing this).

I played around with it for a few days, got it picking up my photos, music and ripped DVDs from the NAS, checked it was recording programmes, setup my Electronic Programme Guide (EPG) using XMLTV GUI (incidentally, easier to set this up to put the file, called tvguide.xml into the xmltv folder in the Media Portal programme folder). Setting up the TV channels and then matching them to the EPG was the most laborious process though. I also managed to get hold of some custom channel icons so many of my channels had the channel logos, making them easier to identify.

I installed a copy of SpeedFan to help control my fan speeds, which did make a difference in noise, but as I only had a CPU fan that could be controlled it meant the heat immediately rocketed up, it showed me it was possible though. I also noticed that my optical DVD ROM was way too loud when playing back (optical drives try and spin flat-out all the time, in reality anything over about 1.5x is wasted on playback). Media Portal does come with an option to control the spin speed of a drive, but it didn’t seem to work, although I have an old drive so it may work with newer ones. After much hunting I grabbed a trial copy of AnyDVD, which had the added benefit of making the drive region free and removing those seriously annoying piracy warnings you can’t skip.

I was happy that my hardware was capable of running the software and acting as a PVR, so I decided it was time to make it look and act more like a PVR than a PC.

Adding Hardware

First off was to find a case. I had a full-size ATX motherboard, so that limited my options, getting a sleek slimline case was out of the question, which was probably a good thing anyway, as I believe the old Athlons run very hot, so it would give more room for air circulation. The old machine survived using only three fans: one in the PSU, one on the graphics card and a CPU cooler, no case fans. I’d swapped the graphics card for a passively cooled one, putting the heat in the case up. There aren’t too many HTPC case manufacturers. The most popular seem to be Zalman, Antec and Silverstone. I liked the look, and the price, of the Silverstone LC13 or the Silverstone LC17. In the end I went for the latter, but it was fairly hard to find for sale in the UK. The LC17 is a huge case, with room for two optical drives stacked on top of each other, up to 6 3.5″ drives, a full-size PSU and a full-size ATX board, plus cooling fans.

Checking my old machine I identified the noisiest elements, which seemed to be overwhelmingly the CPU fan (with the graphics card fan gone, which was far noisier). For a replacement I looked for a Zalman flower, which seem to get great reviews and comes with a fan controller, although I was planning on using SpeedFan anyway. There are actually a variety of different models. I settled on the CNPS7000B-CU, fairly cheap, supports a range of CPUs (including the Socket A/462 my Athlon XP uses) and comes with all the mounting brackets.

I knew I needed a larger hard drive to store the recorded shows on. The board was only capable of PATA (parallel ATA) connections, which limited my choice. After much hunting and reading many reviews I settled on a 400Gb Western Digital Caviar.

Lastly I grabbed a few case fans, one 80mm and one 92mm, both Antec TriCools, which are bearing fans, so quiet, and come with three-setting fan controllers built in. The LC17 also comes with two 80mm fans mounted in the case.

The case was the last to arrive, but it was a fairly simple process to transfer all my components over. The CPU cooler just fit without touching the case, meaning the case fan I was going to mount there wouldn’t go. I mounted the 92mm fan, on it’s lowest setting (where it’s silent) to the front of the middle 3.5″ mounting rail. In the end I left the two Silverstone fans where they were, I only connected one, to a motherboard fan slot, thinking it would be controlled by SpeedFan.

I fitted both the HDDs, figuring to use the original 40 Gb as the OS/system disk and the new one for storage. I attached the CPU cooler directly to the motherboard, not using it’s fan controller.

When I fired up the machine I was expecting whisper-quiet. That’s not what I got. I spent some time starting and stopping the machine to find the noisy components. There seemed to be three culprits: the original 40 Gb HDD, the CPU fan and the two Silverstone case fans. I removed the IBM HDD, it was an old 7,200 RPM drive, hardly surprising it was noisy, then found that the WD drive was mounted using the wrong size screws, so it still had movement, I found the correct screws and bolted it in tight.

I attached the fan controller that came with the CPU cooler and set that to about as low as it would go, I also ordered a couple of Zalman Fanmate 2 controllers (which is what came with the CPU) for the case fans, and again, set them low (the noise from the case fans was more due to the amount of air they were shifting than any noise from the fans).

It meant reinstalling the OS and setting up all the software again, luckily I found out how to backup the Media Portal settings. After a few days waiting for parts and then several hours reinstalling everything I was back in business, but the machine was still too noisy (my aim was a machine you could barely hear when it was running). I checked the case again, the HDD was making a noise, where it was quiet/silent before. I figured my bolting down the drive hadn’t helped, so switched the screws back, giving the drive some play, and that dropped the noise.

As a side note, from what I read the quietest drives are 2.5″ laptop drives, mounted on rubber bungies to stop vibrations being transmitted into the case. This was designed as a low-cost project, so I didn’t want the premium of a 2.5″ drive.

It still wasn’t quiet enough for me though, there was still too much noise, enough that my ears gave a sigh of relief when I turned the machine off. Hunting through the case I found three sources: the CPU cooler, although quiet, was still not silent; the HDD was making some noise, though not much and the PSU, although quiet, was far from silent. I decided I could live with the first two. The PSU was an old one I had left over, although supposedly silent, it blatantly wasn’t. I hunted around and there were plenty of options for a ‘semi-passive’ PSU (which means it runs fanless below a certain temperature, above that a big fan cuts in, typically bigger than 80mm so it can turn slow). I didn’t want semi-passive, that still left the possibility for noise, I wanted silent, which meant fanless. I had the case cooling to cope with the extra heat and the LC17 case has the PSU on it’s own, away from everything else, with a vent straight out of the case.

There aren’t many fanless PSUs, certainly not many at reasonable cost (and forget it if you have a powerful system, mine was all running from a 300w PSU). Many of those mentioned over at SilentPCReview.com just could not be found for sale. In the end I managed to get my hands on a Silverstone ST30NF, figuring it would go well with the case.

The presented a different problem, however, it comes with a 24-pin ATX cable, my board is an old one with a 20-pin socket, which meant buying a converter cable (24-pins are basically 20-pin adapters, with an additional four pins bolted on the side, many PSU manufacturers allow them to be detached, or let them hang separate so you can plug them in or not depending on your board).

You can find part three here